Open Forum

  • 1.  Posted Purchase Invoice posted but the Drect Cost Entries did not post

    Posted Oct 22, 2021 10:55 AM
    I am puzzled by this one. We have Posted Purchase Invoices that the Offset Direct Cost Entries did not post. I am not sure why.  More back ground on this one. This started on Monday 10/18/21 which is also the same day I started working on trimming down permission sets for Accounts Payable. (Not sure this has any bearing however I wanted to tell the complete tale). Attached is a screenshot from 10/15/21 when it was working and from 10/18/21 when it stopped working. This has not posted correctly since 10/15/21.

    NAV 2017 on-prem

    ------------------------------
    Troy Harkness
    Miller Baking Company
    Milwaukee, WI
    ------------------------------


  • 2.  RE: Posted Purchase Invoice posted but the Drect Cost Entries did not post

    GOLD CONTRIBUTOR
    Posted Oct 25, 2021 10:07 AM
    I am not sure I am 100% clear what is going on here based on the screenshots, but NAV/BC posts 2 entries when you post a purchase invoice for an inventory item:  1) an entry to record the payable which debits a Purchases Account and credits A/P and 2) an inventory entry which debits Inventory and credits Direct Cost Applied (commonly referred to as Purchase offset, which i think is what you are referring to).
    One reason these entries may have stopped is because there is a setting on the Inventory Setup page called "Automatic Cost Posting".  When this is turned on, both entries above are posted during the Invoice Post.  If this is turned off, you need to manually run the "Post Inventory Cost to G/L" process.  You can run this process whenever you want and if there is nothing to post, it will be very fast and not create entries.  But if there are any entries for which G/L entries haven't been created yet, it will generate all of the required entries. You can even run it as a Preview without checking the "Post" button to see what entries/if any are out there that need to be posted.

    ------------------------------
    Ken Sebahar
    Solution Systems, Inc.
    ken@solsyst.com
    Podcast: A Shot of Business Central and a Beer!
    ------------------------------



  • 3.  RE: Posted Purchase Invoice posted but the Drect Cost Entries did not post

    GOLD CONTRIBUTOR
    Posted Oct 26, 2021 10:52 AM
    We are also on NAV 2017 and it sounds like what is happening is what recently happened to us.  I did some digging and found this version had a 'feature' (ahem) that when using RapidStart, it turns off the "Automatic Cost Posting" flag in Inventory Setup while running.  If RapidStart fails to complete correctly, the flag is not turned back on.  I had this happen on 10/5 and suddenly even though we ran Adjust Cost nightly, it stopped posting the entries.

    I hope this helps.  Here is the article I found that was most helpful:

    https://www.navug.com/communities/community-home/digestviewer/viewthread?GroupId=49&MessageKey=290d6b84-a8b5-4cd8-8205-6916a13e0e73&CommunityKey=95503735-5a0b-4af1-8326-9bd7bb3b4d3d&tab=digestviewer

    ------------------------------
    Andrea Wasley
    Project Manager
    NOCO Energy Corp.
    Tonawanda NY
    ------------------------------



If you've found this thread useful, dive deeper into User Group community content by role