Open Forum

Expand all | Collapse all

Visual Studio Code error Publishing to latest version 18 preview

  • 1.  Visual Studio Code error Publishing to latest version 18 preview

    SILVER CONTRIBUTOR
    Posted 13 days ago
    I know this error is being discussed few times, but this is the latest BC version 18 (preview) and with the latest AL extension 6.6

    This AL extension version for Visual Studio Code cannot be used with the specified server.
    Please update the AL extension from the Visual Studio Code marketplace.

    Additional information:
    Server details
    - Runtime: 7.0
    - Web API: 4.0
    - Debugger: 4.0

    AL extension details
    - Supported runtimes: 1.0, 2.0, 2.1, 2.2, 2.3, 2.4, 3.0, 3.1, 3.2, 4.0, 4.1, 4.2, 4.3, 4.4, 4.5, 5.0, 5.1, 5.2, 5.3, 6.0, 6.1, 6.2, 6.3, 6.4, 6.5, 6.6
    - Supported Web API: 1.0, 2.0, 3.0, 4.0
    - Supported debuggers: 1.0, 2.0, 3.0

    [Open launch.json] [Cancel]


    ------------------------------
    Carlos Garcia
    KOPIS, LLC
    Miami FL
    ------------------------------


  • 2.  RE: Visual Studio Code error Publishing to latest version 18 preview

    SILVER CONTRIBUTOR
    Posted 11 days ago
    Edited by Carlos Garcia 11 days ago
    I got a response via email and basically says...We need to wait for 7.0 AL extension that is only available for insiders. Wait until next week. However I found they already released today April 1



    ------------------------------
    Carlos Garcia
    KOPIS, LLC
    Miami FL
    ------------------------------



If you've found this thread useful, dive deeper into User Group community content by role