Message Image  

Open Forum

BC Get New Users from O365 failed

  • 1.  BC Get New Users from O365 failed

    Posted Apr 12, 2021 11:53 AM
    Edited by Stephen Hoffort Apr 13, 2021 11:56 AM
    A call to Microsoft.Dynamics.Nav.AzureADGraphClient.GraphQuery.GetUsersPage failed with this message: Could not load file or assembly 'System.Text.Encodings.Web, Version=4.0.4.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

    ------------------------------
    Stephen Hoffort
    CFO
    4036500530
    Calgary AB
    ------------------------------

    So I also posted this on the BC Community Forum and received an answer to my question but NOT a solution.

    Marco Mels responded on 13 Apr 2021 7:59 AM
    BC Get New Users from O365 Failed
    Verified

    Hello,

    This is a known issue unfortunately. In short, a recent hotfix affected Business Central's ability to do outgoing calls to the Microsoft Graph. That hotfix is being rolled back.

    As soon we hit your tenant (automatic uninstall of the deployed hot fix), the issue will be mitigated. Feel free to raise a support request so that we can tell you more precise when this issue will be resolved for your tenant specifically.

    Thanks.

    I understand that I need to either like the reply (which is definitely NOT the case) or identify that you have answered my question.  I will hit verify but I'm making the statement that I don't LIKE the reply as it more or less puts Microsoft off the hook for not testing basic functionality of a hotfix before forcing it on others.  I will identify as answered but what good does it do if there is no way to fix this ISSUE??

    That's all just completely wrong in every way for an ERP to behave.



If you've found this thread useful, dive deeper into User Group community content by role