Open Forum

Expand all | Collapse all

Connecting to BC on-prem with PowerBI

  • 1.  Connecting to BC on-prem with PowerBI

    TOP CONTRIBUTOR
    Posted Dec 21, 2020 08:13 AM

    Hi All

    Trying to connect to PowerBi on BC2020 on-prem

    Following docs here: Building Reports in Power BI Desktop to Display Business Central Data - Business Central

    • No base URL is set in the settings
      Port is 16078
      oData v3 and v4 are enabled

    I verified oData services are running by going to this URL in a browser and logging in with navadmin creds

    http://<Server>:16078/<instance>/oData/Company('Training')

    When I try to connect in PowerBI I use either URL:

    • http://<server>:16078/<instance>/oData 
    • http://<server>:16078/<instance>/oDatav4

    I get this error:

    • "We couldn't authenticate with the credentials provided"

    Anyone got any suggestions?

    Thanks

    Mark



    ------------------------------
    Mark Anderson
    Director of ERP Systems
    Clesen Wholesale
    Evanston, IL
    ------------------------------
    Digital Acceleration Binge Day.  January 28th 2021 | 11:00 AM - 2:00 PM EST


  • 2.  RE: Connecting to BC on-prem with PowerBI

    GOLD CONTRIBUTOR
    Posted Dec 22, 2020 09:30 AM

    Are you working remotely?

     

    The only way I could get this to work was by IP address.

     

    -Devora




    Digital Acceleration Binge Day.  January 28th 2021 | 11:00 AM - 2:00 PM EST


  • 3.  RE: Connecting to BC on-prem with PowerBI

    TOP CONTRIBUTOR
    Posted Dec 23, 2020 09:32 AM

    No, I'm in office. It's definitely reaching nav server as I get a different message if I put in wrong address



    ------------------------------
    Mark Anderson
    Director of ERP Systems
    Clesen Wholesale
    Evanston, IL
    ------------------------------

    Digital Acceleration Binge Day.  January 28th 2021 | 11:00 AM - 2:00 PM EST


  • 4.  RE: Connecting to BC on-prem with PowerBI

    Posted Dec 22, 2020 09:59 AM

    Hi Mark, I get a similar error when attempting to connect using the Nav or Business Central connector in PowerBI, but the generic "ODATA feed" connector in powerbi connects fine.  Have you tried or had success connecting that way?



    ------------------------------
    Mike Ashley
    Arbor Day Foundation
    Lincoln NE
    ------------------------------

    Digital Acceleration Binge Day.  January 28th 2021 | 11:00 AM - 2:00 PM EST


  • 5.  RE: Connecting to BC on-prem with PowerBI

    TOP CONTRIBUTOR
    Posted Dec 23, 2020 09:33 AM

    Not yet. Was naively expecting something that said Business Central on-prem to work with business central on-prem



    ------------------------------
    Mark Anderson
    Director of ERP Systems
    Clesen Wholesale
    Evanston, IL
    ------------------------------

    Digital Acceleration Binge Day.  January 28th 2021 | 11:00 AM - 2:00 PM EST


  • 6.  RE: Connecting to BC on-prem with PowerBI

    SILVER CONTRIBUTOR
    Posted Dec 22, 2020 11:25 AM

    We had the same issue.

    We actually getting data directly from SQL. We have cubes that runs every x amount for time and some set up as a direct query.

    For sure we need to investigate the ODATA connection



    ------------------------------
    Juan F Martinez
    Wholesum Family Farms Inc.
    Nogales AZ
    ------------------------------

    Digital Acceleration Binge Day.  January 28th 2021 | 11:00 AM - 2:00 PM EST


If you've found this thread useful, dive deeper into User Group community content by role