Open Forum

1.  Error Posting Purchase Invoices

Posted 5 days ago
Trying to post Purchase Invoices and we are receiving the following error:

Inventory Adjmt. Account must have a value in General Posting Setup: Gen. Bus. Posting Group=, Gen. Prod. Posting Group=AA. It cannot be zero or empty.

We understand that in the General Posting Setup there is a column for this but this would be for when adjustments are being done which in this case we are just trying to post AP invoices.

Any thoughts and suggestions on a resolution would be greatly appreciated!

Thank you!

------------------------------
Lori McElroy
The Sporn Company
Burlington VT
------------------------------


2.  RE: Error Posting Purchase Invoices

Posted 3 days ago
Hi Lori,

Even though you are not posting a purchase and not an adjustment, the posting code in NAV still validates/tests to see if certain account number fields are populated in the General Posting Setup record related to the combination of General Business and General Product Posting Groups used in the transaction.

I suggest a quick peek at the following: https://msdn.microsoft.com/en-us/library/hh168291(v=nav.90).aspx and https://msdn.microsoft.com/en-us/library/hh172127(v=nav.90).aspx

Hope that helps.

------------------------------
AJ Ansari
NAV Product Manager
InterDyn BMI
Houston TX
------------------------------



3.  RE: Error Posting Purchase Invoices

Posted 2 days ago
Lori,

As mentioned, you need to have all the GL Posting accounts setup with account numbers. Even if it is posting a zero dollar amount it would need to know where to go. Just go to the Gen. Prod Posting setup, make sure the Gen. Bus. Posting group is listed and have the account numbers populated. Once you do that you should have no problems.

Shawn

------------------------------
Shawn Landers
Business Solutions Manager
FoodState
Manchester NH
------------------------------